Pink discharge on Endometrin applicator?!

Discussion forum for those particularly interested in IVF and embryo transfer including frozen embryo transfer.
Post Reply
Bubbles13
Member
Posts: 77
Joined: Tue Aug 19, 2008 8:21 pm

Pink discharge on Endometrin applicator?!

Post by Bubbles13 » Tue Nov 10, 2009 3:20 pm

Hi, I'm 5 weeks 3 days pregnant today and on endometrin suppositories twice/day. This morning before leaving for work, I noticed a small amount of medium colored pink discharge on the applicator after I took it out(I always check...not sure for what). Have been a wreck since (given my history of m/c last FET, however w/ that I never had any spotting). I went to the bathroom at work after that but thankfully didn't see anything on the TP when I wiped.

Called the doc, and the nurse called back and said Dr. isn't concerned and its commonly reported by endometrin users and most common reason is that the cervix could be irritated b/c of the applicator? I'm really really scared...any advice from someone who has gone through this or knows anything about it?
ME: 32/ DH: 32 (Unexplained Infertility)
IUI#1& IVF#1-3-BFN; FET#1- BFP (m/c):(
IVF#4 - BFP! Betas (12dpt-561; 14dpt-1482; 18dpt-5956)
U/S at wks - 6.6, 7.4, 8.6, 9.6, 10.5, 12.2- Twins!!:):)
EDD: 07/10/2010

Sponsor
 

fkm7783
Member
Posts: 50
Joined: Sun Jun 28, 2009 7:54 pm

Post by fkm7783 » Tue Nov 10, 2009 3:39 pm

Hi- I had the same thing my last cycle. My RE told me it can be due to irritation or some times you may have inserted the applicator too deep or it goes in the wrong way and it caused a slight nick. I have always been told, as long as the blood is not bright red, it is ok. This cycle I was put on the Progesterone shot to avoid the spotting/bleeding I had with the suppositories. I have had 3 miscarriages and your story is an inspiration. Good luck and blessings for a successful pregnancy!
Unexplained infertility-UGGHHH!!
IUI #1 (10/2008)-chemical pregnancy

IVF #1 & IVF #2-chemical pregnancies

IVF # 3 (11/09) BFP!!! Beta 1: 105 Beta 2: 256 Beta 3: 4000 Thank you God!

Bubbles13
Member
Posts: 77
Joined: Tue Aug 19, 2008 8:21 pm

Post by Bubbles13 » Tue Nov 10, 2009 4:44 pm

Hi fkm7783,
I'm really glad I can be an inspiration...maybe my true panicked self doesn't come out so much in posts:) One thing though my DH and I are sure of is that we are not giving up until we are successful! I guess that keeps me going...

If you don't mind me asking, you mentioned 3 m/c's in your reply to me, and I see 2 chem's in your signature. So this applicator pink spotting was w/ your chemical? Was it ever determined whether it was really caused by the applicator/endometrin or the beginning of your m/c? Lots of luck to you on your current cycle!
ME: 32/ DH: 32 (Unexplained Infertility)
IUI#1& IVF#1-3-BFN; FET#1- BFP (m/c):(
IVF#4 - BFP! Betas (12dpt-561; 14dpt-1482; 18dpt-5956)
U/S at wks - 6.6, 7.4, 8.6, 9.6, 10.5, 12.2- Twins!!:):)
EDD: 07/10/2010

gi
Regular
Posts: 753
Joined: Wed Jul 08, 2009 10:00 am
Location: Ireland

Post by gi » Tue Nov 10, 2009 4:56 pm

Hi bubbles,

I had some very light pink discharge on the tip of applicator when i used it, after worrying over beta numbers as well i went in for an early scan at 6 wks and all was fine. I did end up having a miscarrige at 10wks but it didnt have anything to do with the pink discharge on applicator tip. I know how worrying it is esp. when you have already had a miscarriage but you are right we gotta keep going and believe it can finally happen. If you start to stress over it insist on an early scan just to ease your mind and help you relax a little bit. Best of luck for you and your little miracle.

gi xxx
7th IVF finally our precious miracle girl Kayla born 24/11/10, 8th IVF FET Sept 2012 BFP!!!
Its TRIPLETS!!!!
Image

lisa10
Regular
Posts: 310
Joined: Thu Jul 23, 2009 11:12 pm
Location: Illinois

Post by lisa10 » Tue Nov 10, 2009 6:44 pm

I had the same thing. This clinic said it was from the applicator. No worries!
Me- 32
DH- 32
9/07 through 8/08- 7 failed IUI attempts
8/09 IVF#1- chemical pregnancy
10/17/09 FET 10/30 Beta #1 960 BFP!!!
[img]http://lbdf.lilypie.com/TziDm5.png[/img] God's blessings and baby dust to you all!!!

Bubbles13
Member
Posts: 77
Joined: Tue Aug 19, 2008 8:21 pm

Post by Bubbles13 » Tue Nov 10, 2009 7:26 pm

Phew...thanks so much for your replies..I've been to the bathroom in anticipation of seeing something several times today but nothing else, so hopefully this is just that and not a bad omen

Lisa, congrats, you're a bit ahead of me...have you had your 1st U/S yet?

Are you having any symptoms? Other than the full feeling after eating and stretching feeling in my upper abs and occasional diziness, nothing for me:(...I told DH last night I wish I would just start throwing up already...he told me he can get me some bad sushi if I really want to do that, lol.
ME: 32/ DH: 32 (Unexplained Infertility)
IUI#1& IVF#1-3-BFN; FET#1- BFP (m/c):(
IVF#4 - BFP! Betas (12dpt-561; 14dpt-1482; 18dpt-5956)
U/S at wks - 6.6, 7.4, 8.6, 9.6, 10.5, 12.2- Twins!!:):)
EDD: 07/10/2010

KatieG
Regular
Posts: 381
Joined: Sun Dec 30, 2007 4:04 am
Location: Houston, TX

Post by KatieG » Tue Nov 10, 2009 11:49 pm

Bubbles good luck and take it easy. I did not throw up once during my whole pregnancy. I wanted to let you know. I was a bit quizzy at about 10 or so weeks when it was time to eat. But never sick so not everyone gets sick. Hope this helps!
ME 29 DH31
1st IVF Male Factor
DS Parker Born 10-15-08
FET Summer 2010 BFP Twins

Post Reply